Elevated API Errors
Incident Report for Toggl
Resolved
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Dec 12, 2024 - 23:36 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Dec 12, 2024 - 22:47 UTC