Elevated API Errors

Incident Report for Toggl

Resolved

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 03, 2025 - 11:15 UTC

Update

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 03, 2025 - 10:56 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 03, 2025 - 10:56 UTC