Elevated Web Application Errors

Incident Report for Toggl

Resolved

We release fixes to the Web Application errors we were experiencing and validated that they are now resolved.
Posted Apr 11, 2025 - 16:35 UTC

Investigating

We're experiencing an elevated level of errors on our Web Application and are currently looking into the issue.
Posted Apr 11, 2025 - 12:53 UTC