Elevated API Errors
Incident Report for Toggl
Resolved
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 04, 2025 - 04:16 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 04, 2025 - 04:12 UTC