Elevated API Errors

Incident Report for Toggl

Resolved

We release fixes to the API errors we were experiencing and validated that they are now resolved.
Posted Mar 21, 2025 - 14:31 UTC

Update

We're currently investigating errors on our API and coming up with a solution for them.
Posted Mar 21, 2025 - 14:27 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 21, 2025 - 14:27 UTC