Elevated API Errors
Incident Report for Toggl
Resolved
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jan 06, 2025 - 18:36 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jan 06, 2025 - 18:32 UTC