Elevated API Errors

Incident Report for Toggl

Resolved

We release fixes to the API errors we were experiencing and validated that they are now resolved.
Posted Apr 14, 2025 - 16:28 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Apr 14, 2025 - 16:07 UTC