Elevated Web Application Errors

Incident Report for Toggl

Resolved

We release fixes to the API errors we were experiencing and validated that they are now resolved.
Posted Apr 14, 2025 - 13:29 UTC

Update

We're currently investigating errors on our API and coming up with a solution for them.
Posted Apr 14, 2025 - 13:28 UTC

Update

We're currently investigating errors on our Web Application and coming up with a solution for them.
Posted Apr 14, 2025 - 13:15 UTC

Investigating

We're experiencing an elevated level of errors on our Web Application and are currently looking into the issue.
Posted Apr 14, 2025 - 13:14 UTC