Elevated API Errors

Incident Report for Toggl

Resolved

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 16, 2025 - 22:50 UTC

Update

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 16, 2025 - 22:32 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 16, 2025 - 22:31 UTC