Elevated Web Application Errors

Incident Report for Toggl

Resolved

We release fixes to the API errors we were experiencing and validated that they are now resolved.
Posted Mar 02, 2026 - 16:13 UTC

Update

We're currently investigating errors on our API and coming up with a solution for them.
Posted Mar 02, 2026 - 16:08 UTC

Update

We are continuing to work on a fix for this issue. Some report generation are still affected
Posted Mar 02, 2026 - 15:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2026 - 15:01 UTC

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 14:47 UTC

Update

We're currently investigating errors on our Web Application and coming up with a solution for them.
Posted Mar 02, 2026 - 14:25 UTC

Investigating

We're experiencing an elevated level of errors on our Web Application and are currently looking into the issue.
Posted Mar 02, 2026 - 14:19 UTC
This incident affected: Track (Reports).